Kategorien
News

Ehemalige NAS SSDs nicht mehr formatierbar und defekt? Vonwegen!

Ehemalige NAS SSDs nicht mehr formatierbar und defekt? Vonwegen!

Problembeschreibung

Heute möchte ich einen Techniker-Fall bei uns aus dem Verein beschreiben, der meine eigene Hardware betrifft. Dabei wurde mir von einem Vereinsmitglied unbürokratisch und mit breitem Fachwissen geholfen.

Meine zwei 1TB Consumer-SSDs (Crucial MX500), die ich in meinem bereits verkauften QNAP-NAS (TS-253D) betrieben habe, wollte ich verkaufen. Die beiden SSDs waren im RAID1 konfiguriert, d.h. die Daten wurden gespiegelt und damit sicher abgelegt. Natürlich weiß ich, dass für den Einsatz in einem NAS eher entsprechende NAS Geräte geeignet sind. In meinem neuen NAS habe ich auch keine Consumer Geräte mehr eingebaut. Unabhängig davon wollte ich natürlich vor Verkauf meine Daten komplett löschen. Am besten per vollständiger Formatierung und folgendem Erase mit Nullen. Leider musste ich feststellen, dass die Formatierung immer wieder fehlgeschlagen ist. Sind die SSDs jetzt defekt? Beide gleichzeitig? Unwahrscheinlich. Also ab zur Fehleranalyse.

Crucial MX500 2.5″ SSD – CT1000MX500SSD1 – Links ist die PSID zu sehen

Fehleranalyse

Ich habe die Formatierung über gparted in Kubuntu angestoßen. Davor habe ich die Partitionstabelle gelöscht und neu angelegt – das hat auch ohne Fehler funktioniert. Die Formatierung schlägt jedoch immer wieder fehl, nach etwa 30 Sekunden. Eine wirkliche Fehlermeldung habe ich nicht bekommen.

Als nächstes wollte ich das ganze unter Windows versuchen. Also Windows 10 gestartet und mit diskmgmt.msc die Datenträgerverwaltung geöffnet. Da kam die Überraschung. Die zwei vorherigen Partitionen waren noch vorhanden?! Scheinbar hat auch das Löschen der Partitionstabelle nicht funktioniert, obwohl kein Fehler kam. Eigenartig. OK aus meiner Ausbildungszeit kannte ich noch das kleine hilfreiche Tool „Crystal Disk Info“ – runtergeladen, ausgeführt. Die ausgelesenen S.M.A.R.T Werte waren alle wunderbar in Ordnung auf beiden SSDs. Danach habe ich die Volumes über Windows versucht zu löschen und die Formatierung zu starten. Löschen ging wieder, aber die Formatierung ist nach 30 Sekunden abgebrochen – dabei wurde sogar im Moment des Fehlschlags die SSD kurz getrennt und wieder verbunden.

Weiter gehts mit klassischen Troubleshooting. Hier mal aufgelistet, was ich versucht habe:

  • Austausch des SATA Adapters
  • Austausch des SATA Kabels
  • Anderes USB Kabel
  • Anderer USB Port auf Rechnerrückseite
  • chkdsk E: /f /r
  • Nochmal das Ganze in Kubuntu mit der eingebauten Partitionsverwaltung
  • Herstellertool: In diesem Fall Crucial Storage Executive
    • Neuste Firmware war bereits installiert
    • Laufwerk Bereinigung
    • Laufwerk Formatierung
    • Geräte Selbsttest

All das oben erwähnte hat nicht zum Erfolg geführt… Leider… Das chkdsk ist über Nacht gelaufen und letztendlich gab es viele Fehler im Eventlog – a la „Sektor nicht lesbar – wird übersprungen“. Am Ende hatte ich eine ~9GiB SSD. Für die eigentlichen 1TB deutlich zu wenig, aber ein Hinweis. Was kann das Problem hier nur sein? Eine Vermutung: QNAP verschlüsselt die SSDs bei Installation des eigenen Betriebssystems (QTS) in einem Dateiformat, mit dem andere Betriebsysteme nicht umgehen können. Die 9GiB könnten der „unbeschränkte“ Teil der QNAP Formatierung sein. Das war lediglich eine Vermutung…

In einer solchen Situation stößt man häufig auf Schlaufüchse, die davon ausgehen, dass die SSD einfach nun defekt ist, weil dies angeblich häufig passiert… Kann sein, aber zwei SSDs gleichzeitig? Sehr unwahrscheinlich, auch wenn sie aus der selben Charge sind.

Also habe ich das Problem im letzten Montag Termin beschrieben. Hier gab es viele nützliche Tipps. Unter anderem folgenden:

Hier habe ich unter Anleitung ein Wipe und Erase getestet. Beides ohne Erfolg.

Schlussendlich gab es persönliche Hilfe von einem Vorstandsmitglied. Dieser hat erst das gleiche Fehlerbild wie ich festgestellt. Jedoch konnte er mein Problem lösen!

Die Lösung

Ich hatte es fast versucht, mir von der Methode aber keinen Erfolg versprochen. Das Tool „Crucial Storage Executive“ bietet die Möglichkeit „PSID-Wiederherstellung“. Hier muss man die PSID Kennung die auf der SSD Rückseite angedruckt ist eingeben. Dadurch wird die SSD scheinbar neu initialisiert. Und siehe da: Die SSDs ließen sich beide ohne Probleme formatieren. In Windows sowie in Linux! Wunderbar.

Leider habe ich keinen Screenshot mehr mit angeschlossener SSD

Danke united.help

Markus

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert